Thornsoft BugFix Tracking

Thornsoft Bug/Fix Tracking

Copyright 2004, Thornsoft Development, Inc.

  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000183 [ClipMate 6] Crashes / Error Messages major random 05-11-04 10:53 05-27-04 11:21
Reporter Chris Thornton View Status public  
Assigned To Chris Thornton
Priority high Resolution fixed  
Status resolved   Product Version 6.3.04
Summary 0000183: Access Violation during Printing, or when viewing User Preferences
Description Random error when using print preview. Since User Preferences has a print preview built-in, it's susceptible to the same problem, even when you're not printing anything.
Additional Information Call Stack Information:
------------------------------------------------------------------------------------------
|Address |Module |Unit |Class |Procedure/Method |Line|
------------------------------------------------------------------------------------------
|77F51125|ntdll.dll | | |RtlLeaveCriticalSection | |
|77F09A53|GDI32.dll | | |GetTextExtentPoint32A | |
|77F09A40|GDI32.dll | | |GetTextExtentPoint32A | |
|00698C8B|ClipMt63.exe|clipobj.pas |TClipObj |STimeStamp |1552|
|00698C48|ClipMt63.exe|clipobj.pas |TClipObj |STimeStamp |1549|
|006AF3B9|ClipMt63.exe|Main.pas | |DrawClipHeader |5675|
|77F51125|ntdll.dll | | |RtlLeaveCriticalSection | |
|77F51125|ntdll.dll | | |RtlLeaveCriticalSection | |
|77F51125|ntdll.dll | | |RtlLeaveCriticalSection | |
|006AF26C|ClipMt63.exe|Main.pas | |DrawClipHeader |5652|
|006AFF73|ClipMt63.exe|Main.pas |TfrmMain |StringJobDraw |5861|
|00588D06|ClipMt63.exe|PSJob.pas |TCustomPrintJob |DrawArea |641 |
|00588CD0|ClipMt63.exe|PSJob.pas |TCustomPrintJob |DrawArea |639 |
|00675D95|ClipMt63.exe|PJStrings.pas|TCustomStringsPrintJob|DrawArea |293 |
|00588A67|ClipMt63.exe|PSJob.pas |TCustomPrintJob |Draw |582 |
|005902B7|ClipMt63.exe|PJMulti.pas |TCustomMultiPrintJob |Draw |257 |
|0058BA4E|ClipMt63.exe|PSPreview.pas|TCustomPreview |Update |460 |
|0058BEFB|ClipMt63.exe|PSPreview.pas|TCustomPreview |SetPrintJob |684 |
|0058BEA8|ClipMt63.exe|PSPreview.pas|TCustomPreview |SetPrintJob |676 |
|00670701|ClipMt63.exe|SetFrm6.pas |TfrmSettings |FormCreate |1181|
|77F51125|ntdll.dll | | |RtlLeaveCriticalSection | |
|006A8E74|ClipMt63.exe|Main.pas |TfrmMain |act_UserPrefsExecute |3688|
|77CC9502|kernel32.dll| | |WaitForMultipleObjectsEx| |
|77E6B1B5|USER32.dll | | |DispatchMessageA | |
|77E6B1AB|USER32.dll | | |DispatchMessageA | |
|00484C4A|ClipMt63.exe|PGTray95.pas | |RunTrayApplication |1936|
|00484C38|ClipMt63.exe|PGTray95.pas | |RunTrayApplication |1935|
|006B276A|ClipMt63.exe|ClipMt63.dpr | | |151 |
|77F5D878|ntdll.dll | | |ZwAllocateVirtualMemory | |
|77F5D86E|ntdll.dll | | |ZwAllocateVirtualMemory | |
------------------------------------------------------------------------------------------
Fixed In Release 6.3.05.464
Attached Files

- Relationships

- Notes
(0000021)
Chris Thornton
05-11-04 10:55

Call Stack Information:
-----------------------------------------------------------------------------------------
|Address |Module |Unit |Class |Procedure/Method |Line|
-----------------------------------------------------------------------------------------
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|7E09BF7F|GDI32.dll | | |GetTextExtentPoint32A | |
|7E09BF6D|GDI32.dll | | |GetTextExtentPoint32A | |
|00698C8B|ClipMt63.exe|clipobj.pas |TClipObj |STimeStamp |1552|
|00698C48|ClipMt63.exe|clipobj.pas |TClipObj |STimeStamp |1549|
|006AF3B9|ClipMt63.exe|Main.pas | |DrawClipHeader |5675|
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|006AF26C|ClipMt63.exe|Main.pas | |DrawClipHeader |5652|
|006AFF73|ClipMt63.exe|Main.pas |TfrmMain |StringJobDraw |5861|
|00588D06|ClipMt63.exe|PSJob.pas |TCustomPrintJob |DrawArea |641 |
|00588CD0|ClipMt63.exe|PSJob.pas |TCustomPrintJob |DrawArea |639 |
|00675D95|ClipMt63.exe|PJStrings.pas|TCustomStringsPrintJob|DrawArea |293 |
|00588A67|ClipMt63.exe|PSJob.pas |TCustomPrintJob |Draw |582 |
|005902B7|ClipMt63.exe|PJMulti.pas |TCustomMultiPrintJob |Draw |257 |
|0058BA4E|ClipMt63.exe|PSPreview.pas|TCustomPreview |Update |460 |
|0058BC12|ClipMt63.exe|PSPreview.pas|TCustomPreview |WndProc |587 |
|77F59BA7|ntdll.dll | | |RtlAcquirePebLock | |
|77F59BAE|ntdll.dll | | |RtlAcquirePebLock | |
|77F941F8|ntdll.dll | | |RtlInitUnicodeString | |
|77F59BF6|ntdll.dll | | |RtlReleasePebLock | |
|77F59BEA|ntdll.dll | | |RtlReleasePebLock | |
|77FA3615|ntdll.dll | | |bsearch | |
|77F86062|ntdll.dll | | |RtlHashUnicodeString | |
|77D494E8|USER32.dll | | |GetClassInfoA | |
|77D48B3E|USER32.dll | | |CreateWindowExA | |
|77D48B12|USER32.dll | | |CreateWindowExA | |
|0058B426|ClipMt63.exe|PSPreview.pas|TCustomPreview |Update |357 |
|0058BEFB|ClipMt63.exe|PSPreview.pas|TCustomPreview |SetPrintJob |684 |
|0058BEA8|ClipMt63.exe|PSPreview.pas|TCustomPreview |SetPrintJob |676 |
|00670701|ClipMt63.exe|SetFrm6.pas |TfrmSettings |FormCreate |1181|
|77D78680|USER32.dll | | |DdeQueryStringA | |
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|006A8E74|ClipMt63.exe|Main.pas |TfrmMain |act_UserPrefsExecute |3688|
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|77F5B380|ntdll.dll | | |RtlLeaveCriticalSection| |
|77D4436F|USER32.dll | | |DispatchMessageA | |
|77D44369|USER32.dll | | |DispatchMessageA | |
|00484C4A|ClipMt63.exe|PGTray95.pas | |RunTrayApplication |1936|
|00484C38|ClipMt63.exe|PGTray95.pas | |RunTrayApplication |1935|
|006B276A|ClipMt63.exe|ClipMt63.dpr | | |151 |
|77F5B552|ntdll.dll | | |NtAllocateVirtualMemory| |
|77F5B548|ntdll.dll | | |NtAllocateVirtualMemory| |
-----------------------------------------------------------------------------------------
 
(0000031)
Chris Thornton
05-26-04 15:33

Removed preview from user preferences in v6.3.05.464, to minimize impact.
 
(0000032)
Chris Thornton
05-27-04 11:21

Note: as part of this fix, the preview has been removed from the
    User Preferences dialog. This will improve the performance of the
    dialog, and will eliminate navigation problems caused by the
    delay in displaying the Print Options page of the User Preferences dialog.
 

- Issue History
Date Modified Username Field Change
05-11-04 10:53 Chris Thornton New Issue
05-11-04 10:55 Chris Thornton Note Added: 0000021
05-26-04 15:33 Chris Thornton Note Added: 0000031
05-27-04 11:14 Chris Thornton Status assigned => resolved
05-27-04 11:14 Chris Thornton Resolution open => fixed
05-27-04 11:15 Chris Thornton Status resolved => feedback
05-27-04 11:15 Chris Thornton Resolution fixed => reopened
05-27-04 11:16 Chris Thornton Fixed In Release  => 6.3.05.464
05-27-04 11:16 Chris Thornton Status feedback => resolved
05-27-04 11:16 Chris Thornton Resolution reopened => fixed
05-27-04 11:21 Chris Thornton Status resolved => feedback
05-27-04 11:21 Chris Thornton Resolution fixed => reopened
05-27-04 11:21 Chris Thornton Note Added: 0000032
05-27-04 11:21 Chris Thornton Status feedback => resolved
05-27-04 11:21 Chris Thornton Resolution reopened => fixed
All content copyright 2003

All content copyright 2004, Thornsoft Development, Inc. 

ClipMate Home ClipMate FAQ ClipMate Forum Darn! Home Darn FAQ Darn Forum


Mantis 1.0.6[^]
Copyright © 2000 - 2006 Mantis Group
38 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker