Thornsoft BugFix Tracking

Thornsoft Bug/Fix Tracking

Copyright 2004, Thornsoft Development, Inc.

  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000193 [Darn! Passwords! v3.1] Pro feature always 05-25-04 11:38 08-04-04 10:09
Reporter Chris Thornton View Status public  
Assigned To Chris Thornton
Priority normal Resolution reopened  
Status assigned   Product Version
Summary 0000193: Problems with countdown logout / closing
Description R.K. Notes:
I left Darn! running in the toolbar mode, when it "times out" the form
should expand back to the sign-in screen or minimize. It currently stays as
a toolbar, but the arrow doesn't work and I ended up having to maximize the
form to log back in. And you can't sign in from the toolbar mode.
Additional Information Also, the countdown timer makes the menu wider, causing it to wrap, which messes up the "collapse to toolbar" button.
Fixed In Release 3.1.03.41
Attached Files

- Relationships

- Notes
(0000025)
Chris Thornton
05-25-04 11:49

This one is related:

Call Stack Information:
---------------------------------------------------------------------------------
|Address |Module |Unit |Class |Procedure/Method |Line|
---------------------------------------------------------------------------------
|004439DA|DarnPwrd.exe|EDarnPnl.pas|TEDarnPnl |EditClick |845 |
|77D440B8|USER32.dll | | |GetWindowLongW | |
|77D440C1|USER32.dll | | |GetWindowLongW | |
|77D440C1|USER32.dll | | |GetWindowLongW | |
|00425F44|DarnPwrd.exe|ThemeMgr.pas| |Compare |609 |
|004260C1|DarnPwrd.exe|ThemeMgr.pas|TWindowProcList|Find |728 |
|77D45F6E|USER32.dll | | |CallWindowProcA | |
|77D45F5A|USER32.dll | | |CallWindowProcA | |
|00425F44|DarnPwrd.exe|ThemeMgr.pas| |Compare |609 |
|004260C1|DarnPwrd.exe|ThemeMgr.pas|TWindowProcList|Find |728 |
|00426027|DarnPwrd.exe|ThemeMgr.pas|TWindowProcList|DispatchMessage |680 |
|00425FE8|DarnPwrd.exe|ThemeMgr.pas|TWindowProcList|DispatchMessage |670 |
|0042784E|DarnPwrd.exe|ThemeMgr.pas|TThemeManager |PanelWindowProc |1593|
|00427628|DarnPwrd.exe|ThemeMgr.pas|TThemeManager |PanelWindowProc |1536|
|004285BC|DarnPwrd.exe|ThemeMgr.pas|TThemeManager |PrePanelWindowProc |2091|
|10005172|ophook32.dll| | |CallWndHook | |
|77D454AF|USER32.dll | | |SendMessageW | |
|77D445B9|USER32.dll | | |GetClientRect | |
|77D440B8|USER32.dll | | |GetWindowLongW | |
|77D45F6E|USER32.dll | | |CallWindowProcA | |
|77D45F5A|USER32.dll | | |CallWindowProcA | |
|77D4436F|USER32.dll | | |DispatchMessageA | |
|77D44369|USER32.dll | | |DispatchMessageA | |
|0044560D|DarnPwrd.exe|DarnPwrd.dpr| | |47 |
|77F5B552|ntdll.dll | | |NtAllocateVirtualMemory| |
|77F5B548|ntdll.dll | | |NtAllocateVirtualMemory| |
---------------------------------------------------------------------------------


This error occurs when you have the details of an entry displayed and then the safe open time runs out. This is not a new bug.
 
(0000029)
Chris Thornton
05-25-04 20:34

Turns out that it may be just any logout in general. Art from SB had the same thing, without the countdown. Just logging out. Blows up line 845. Here's the comment:

We need your help.:
----------------------------------------
Viewed the login and password to get onto a web site and then exited the program. nothing fancy.

Call Stack Information:
---------------------------------------------------------------------------------
|Address |Module |Unit |Class |Procedure/Method |Line|
---------------------------------------------------------------------------------
|004436EE|DarnPwrd.exe|EDarnPnl.pas|TEDarnPnl |EditClick |845 |
|77E13D81|USER32.dll | | |CallWindowProcA | |
|77E13D95|USER32.dll | | |CallWindowProcA | |
|00425F4B|DarnPwrd.exe|ThemeMgr.pas|TWindowProcList|DispatchMessage |680 |
|77F82091|ntdll.dll | | |RtlLeaveCriticalSection| |
|77F82091|ntdll.dll | | |RtlLeaveCriticalSection| |
|77F82091|ntdll.dll | | |RtlLeaveCriticalSection| |
|77E139E0|USER32.dll | | |SendMessageW | |
|77E139A2|USER32.dll | | |SendMessageW | |
|77E13D95|USER32.dll | | |CallWindowProcA | |
|77E13D95|USER32.dll | | |CallWindowProcA | |
|77E13D81|USER32.dll | | |CallWindowProcA | |
|77E15F64|USER32.dll | | |DispatchMessageA | |
|77E15F5E|USER32.dll | | |DispatchMessageA | |
|00445321|DarnPwrd.exe|DarnPwrd.dpr| | |47 |
|77F82AEA|ntdll.dll | | |ZwAllocateVirtualMemory| |
---------------------------------------------------------------------------------
 
(0000034)
Chris Thornton
06-04-04 12:42

Fixed with "vault closed" switch. Also moved the countdown from the menu to the statusbar, to avoid menu-wrapping ugliness.
 
(0000037)
Chris Thornton
08-04-04 10:08

Still happening in 3.1.03
 
(0000038)
Chris Thornton
08-04-04 10:09

Additional Feedback:
We need your help.:
----------------------------------------
I had left my 'Darn! Passwords!' application open with a password dialog up when I put my Windows XP session to 'sleep' last night.

I came into work this morning, 'awoke' my XP session, noticed that my DP app was up so I closed the password dialog and then attempted to close the DP app itself. At this time it complained of an error.
 

- Issue History
Date Modified Username Field Change
05-25-04 11:38 Chris Thornton New Issue
05-25-04 11:49 Chris Thornton Note Added: 0000025
05-25-04 11:49 Chris Thornton Status new => assigned
05-25-04 11:49 Chris Thornton Assigned To  => Chris Thornton
05-25-04 20:34 Chris Thornton Note Added: 0000029
06-04-04 12:42 Chris Thornton Note Added: 0000034
06-04-04 12:47 Chris Thornton Fixed In Release  => 3.1.03.41
06-04-04 12:47 Chris Thornton Status assigned => resolved
06-04-04 12:47 Chris Thornton Resolution open => fixed
06-04-04 12:47 Chris Thornton Summary Problems with countdown logout => Problems with countdown logout / closing
08-04-04 10:08 Chris Thornton Status resolved => feedback
08-04-04 10:08 Chris Thornton Resolution fixed => reopened
08-04-04 10:08 Chris Thornton Note Added: 0000037
08-04-04 10:09 Chris Thornton Note Added: 0000038
08-04-04 10:09 Chris Thornton Status feedback => assigned
All content copyright 2003

All content copyright 2004, Thornsoft Development, Inc. 

ClipMate Home ClipMate FAQ ClipMate Forum Darn! Home Darn FAQ Darn Forum


Mantis 1.0.6[^]
Copyright © 2000 - 2006 Mantis Group
42 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker